LinkIt Smart 7688 Duo

去年买了两块LinkIt开发板,其WiFi芯片功能非常有限,只支持一种模式(Master/Client),不能直接作为OpenWrt路由器使用。

开发板上除了电源接口外,还有一个MicroUSB接口,可以挂载一个USB设备。刚好手头有个USB无线网卡,通过MicroUSB转USB接口,就能够连接上去。

操作步骤

  • 通电启动 (约30秒)
  • 连接WiFi (LinkIt_Smart_7688_XXXXXX)
  • 连接WiFi (主路由器cisco)
  • 连接WiFi (LinkIt_Smart_7688_XXXXXX)
    • 通过SSH登录
    • 编辑/etc/config/wireless
    • 重启WiFi

固件升级后(v0.9.2->v0.9.3), USB网卡无法正常工作! 只能刷回原版, 浪费半天时间. :(

编辑之前

对相关文件进行备份, 必要时可以还原文件.

  • /etc/config/wireless
  • /etc/config/network
  • /etc/config/firewall
# /etc/config/wireless

config wifi-device  radio1  
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     '101c0000.ehci/usb1/1-1/1-1:1.0'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface  
        option device   radio1
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

编辑之后

建议通过Luci界面, 对网络进行配置. 把握SaveApply的时机.

# /etc/config/wireless

config wifi-device 'radio1'  
           option type 'mac80211'
           option channel '11'
           option hwmode '11g'
           option path '101c0000.ehci/usb1/1-1/1-1:1.0'
           option htmode 'HT20'

config wifi-iface  
           option device 'radio1'
           option mode 'sta'
           option network 'wwan'
           option ifname 'wlan0'
           option ssid 'cisco'
           option key '********'
           option encryption 'psk2'
# /etc/config/network

config interface 'wwan'  
           option proto 'dhcp'
# /etc/config/firewall

config zone  
        option name 'wan'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option network 'wan wan6 wwan'

注意事项

从配置文件上看, radio0开启了AP模式, STA模式已被禁用, 但是不能删除相关配置, 否则radio0将无法工作. 请对Network>Interfaces>WAN视而不见.

串口调试

在配置过程中, 使用USB2TTL, 来解决突发事件.

USB2TTL     LinkIt  
-------     ------
Pin RX  <-> Pin 8  
Pin TX  <-> Pin 9  
Pin GND <-> Pin GND  
$ minicom -D /dev/cu.usbserial -b 57600

科学上网

可以直接使用小米mini的ipk安装包. OUTDATED

$ opkg update

$ wget https://github.com/vimagick/rpi-bin/raw/master/ipk/shadowsocks-libev-spec_2.4.8-2_ramips_24kec.ipk \
       https://github.com/vimagick/rpi-bin/raw/master/ipk/luci-app-shadowsocks-spec_1.5.0-1_all.ipk

$ opkg install shadowsocks-libev-spec_2.4.8-2_ramips_24kec.ipk \
               luci-app-shadowsocks-spec_1.5.0-1_all.ipk \
               iptables-mod-tproxy

$ wget -qO- http://ftp.apnic.net/apnic/stats/apnic/delegated-apnic-latest | awk -F '|' '$2=="CN" && $3=="ipv
4" {printf "%s/%s\n", $4, 32-log($5)/log(2)}' > /etc/ignore.list  

效果图

已知问题